View Issue Details

IDProjectCategoryView StatusLast Update
0000514MantisDroid[All Projects] Defectpublic2013-05-16 20:36
Reportere7andyAssigned Toe7andy 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version2.0Fixed in Version2.0 
Summary0000514: Crash while loading issue notes
DescriptionCrash while loading issue notes.

java.lang.RuntimeException: An error occured while executing doInBackground()
at android.os.AsyncTask$3.done(AsyncTask.java:278)
at java.util.concurrent.FutureTask$Sync.innerSetException(FutureTask.java:273)
at java.util.concurrent.FutureTask.setException(FutureTask.java:124)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:307)
at java.util.concurrent.FutureTask.run(FutureTask.java:137)
at android.os.AsyncTask$SerialExecutor$1.run(AsyncTask.java:208)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1076)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:569)
at java.lang.Thread.run(Thread.java:856)
Caused by: java.lang.ClassCastException: a.b.a.g cannot be cast to a.b.a.j
at se.nextsource.android.mantisdroid.b.d.c(Unknown Source)
at se.nextsource.android.mantisdroid.entity.IssueNoteData.<init>(Unknown Source)
at se.nextsource.android.mantisdroid.entity.IssueNoteData.a(Unknown Source)
at se.nextsource.android.mantisdroid.entity.Issue.<init>(Unknown Source)
at se.nextsource.android.mantisdroid.entity.Issue.a(Unknown Source)
at se.nextsource.android.mantisdroid.b.a.a(Unknown Source)
at se.nextsource.android.mantisdroid.a.a.a(Unknown Source)
at se.nextsource.android.mantisdroid.gui.issue.v.a(Unknown Source)
at se.nextsource.android.mantisdroid.gui.issue.v.doInBackground(Unknown Source)
at android.os.AsyncTask$2.call(AsyncTask.java:264)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:305)
... 5 more

Deobfuscation reveals that a NullSoapObject is being cast to a SoapPrimitive and that is not allowed.
It seems to be more or less an NPE...
TagsNo tags attached.

Activities

e7andy

2013-05-16 16:53

administrator   ~0000143

Last edited: 2013-05-16 16:56

View 3 revisions

test note

e7andy

2013-05-16 20:36

administrator   ~0000145

Catched Exception if creation date of the issue note could not be parsed. Will now return today's date if exception occurs. This should never really occur, but the report says otherwise.

Issue History

Date Modified Username Field Change
2013-05-16 16:53 e7andy New Issue
2013-05-16 16:53 e7andy Note Added: 0000143
2013-05-16 16:54 e7andy Note Edited: 0000143 View Revisions
2013-05-16 16:55 e7andy Note View State: 0000143: public
2013-05-16 16:55 e7andy Note Edited: 0000143 View Revisions
2013-05-16 16:56 e7andy Note View State: 0000143: public
2013-05-16 16:56 e7andy Note View State: 0000143: public
2013-05-16 16:56 e7andy Note View State: 0000143: private
2013-05-16 16:56 e7andy Note View State: 0000143: public
2013-05-16 20:29 e7andy Scrum State => New
2013-05-16 20:29 e7andy Description Updated View Revisions
2013-05-16 20:35 e7andy Assigned To => e7andy
2013-05-16 20:35 e7andy Status new => assigned
2013-05-16 20:36 e7andy Scrum State New => Done
2013-05-16 20:36 e7andy Note Added: 0000145
2013-05-16 20:36 e7andy Status assigned => closed
2013-05-16 20:36 e7andy Resolution open => fixed
2013-05-16 20:36 e7andy Fixed in Version => 2.0