View Issue Details

IDProjectCategoryView StatusLast Update
0000504MantisDroid[All Projects] Defectpublic2013-08-14 19:48
Reportere7andy Assigned Toe7andy  
PriorityimmediateSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.0 
Target Version2.0Fixed in Version2.0 
Summary0000504: User cannot login, err msg "length=8;regionStart=4;regionLength=-5"
DescriptionEvery time the user tries to login he gets the error message:
Something went wrong.
length=8;regionStart=4;regionLength=-5

Error is caused by the MantisBT version name: 1.3.0dev
MantisDroid only handles numerics divided by dots and with an optional "-dev" as suffix.
Fix by adding a more generic function to remove the suffix:
String digits = buildVersionString.replaceAll("[^0-9]", "");
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2013-05-12 18:25 e7andy New Issue
2013-05-12 18:25 e7andy Status new => assigned
2013-05-12 18:25 e7andy Assigned To => e7andy
2013-05-12 18:59 e7andy Scrum State New => In Test
2013-05-12 18:59 e7andy Status assigned => resolved
2013-05-12 18:59 e7andy Fixed in Version => 2.0
2013-05-12 18:59 e7andy Resolution open => fixed
2013-08-14 19:48 e7andy Status resolved => closed